Ask the Expert

Applet doesn't print properly

Hi! I have an applet in a form that displays a pie graphic. It works correctly. The user selects a range date, some information to filter, and (by code) a new document is created; I don't save the new doc, just show it to the user (notesuiwork.Edit). The fields in this doc are hidden. I have a "Title" field and some buttons. The applet is inside a table, to look better. My problem is: the applet doesn't print! I mean, sometimes (very rare) it prints ok, but most of times it won't! What am I doing wrong? Any advice will be appreciated.
Since I haven't worked much with applets, I don't know what the problem might be. But, is it possible that the applet is in constant refresh mode, so that whether you get an image is a matter of timing?

Do you have comments on this Ask the Expert question and response? Let us know.

This was first published in June 2004

There are Comments. Add yours.

 
TIP: Want to include a code block in your comment? Use <pre> or <code> tags around the desired text. Ex: <code>insert code</code>

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
Sort by: OldestNewest

Forgot Password?

No problem! Submit your e-mail address below. We'll send you an email containing your password.

Your password has been sent to: