Ask the Expert

Certain domains don't work for my SMTP connection

I have an SMTP connection to my Web provider to send mail. They all work expect for AOL.com and some other domains. I get the following error in my log:

 09/17/2003 01:04:23 PM SMTP Server: Started 09/17/2003 01:04:23 PM Router: No messages transferred to AOL.COM (host mailin-
03.mx.AOL.COM) via SMTP: SMTP Protocol Returned a Permanent Error 09/17/2003 01:04:23 PM Router: No messages transferred to AOL.COM (host mailin-
02.mx.AOL.COM) via SMTP: SMTP Protocol Returned a Permanent Error 09/17/2003 01:04:23 PM Router: No messages transferred to AOL.COM (host mailin-
01.mx.AOL.COM) via SMTP: SMTP Protocol Returned a Permanent Error 0

Can you help?
It could be that you are being blacklisted because you have an open relay. If not that, then it could be any number of things. If you turn on SMTP debugging, like SMTPClientDebug=3, your log will capture more information and you will be able to determine where the problem is.


Member feedback:
AOL wouldn't return a permanent error if the server was blacklisted. It is more likely to be an issue because the server connecting doesn't have a static IP address (DHCP). You can ask the user to see if this isn't the issue. I've seen problems with AOL before causing the described behavior.

This was first published in October 2003

There are Comments. Add yours.

 
TIP: Want to include a code block in your comment? Use <pre> or <code> tags around the desired text. Ex: <code>insert code</code>

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
Sort by: OldestNewest

Forgot Password?

No problem! Submit your e-mail address below. We'll send you an email containing your password.

Your password has been sent to: